Error Help

Ask questions, discuss ideas, get answers

Error Help

Postby takiwa » Sat Apr 28, 2018 10:10 pm

c:\sandbox\bf1942-head\engine\io\Input.h(170): Error: io: 1 setInput out of range: 55. Max is: 55

does anyone know what this error is referring to? It is popping up on a map now that I previously had no problems with. I added 2 vehicles to the map, but those two vehicles work on all other maps, and when I rem'ed them out of this map I still get the error. That line is straight from the debugger, so I have no more info than that. Also, I get the error when running in bf1942 (not the debugger) as well.

As the only clue I have, it pops up in coop/sp only. multi-player works fine.

Anyone?
Image
takiwa
 
Posts: 103
Joined: Mon Dec 30, 2013 4:29 pm
Location: The Great State of Georgia

Re: Error Help

Postby freddy » Sun Apr 29, 2018 4:38 am

Yes sir! (hopefully)

after you isolate which particular object (usually a weapon) is causing the error, try adding the line:

ObjectTemplate.fire.altFireInput PIAltFire

...into its fireComp. it's usually caused by bots not being able to understand the AltFire setup of the weapon, even if it doesn't have one


http://www.battlefieldsingleplayer.com/ ... 18814.html
User avatar
freddy
 
Posts: 1222
Joined: Sun Oct 18, 2009 4:58 pm

Re: Error Help

Postby takiwa » Sun Apr 29, 2018 5:39 am

I'll take a look and see if I can isolate a weapon with a bad code on the fire command, hopefully this translates to bf1942 as well...

thanks for that link :)
Image
takiwa
 
Posts: 103
Joined: Mon Dec 30, 2013 4:29 pm
Location: The Great State of Georgia


Return to 1942 Modding Discussion

Who is online

Users browsing this forum: No registered users and 20 guests